You are hereForums / By Discipline / Road / Road Gear / Garmin Edge 500 firmware issues

Garmin Edge 500 firmware issues


By keveddy - Posted on 13 October 2012

NB: Originally posted elsewhere on the Global Riders Network and appears via syndication.

Every bloody time... So I just upgraded my Garmin firmware to v3, and now the bloody thing thinks it's moving all the time. Picking up the rotation of the earth, are we?

Anyone else experiencing this problem? If so, is there a fix other than rolling back the firmware to v2.8?

thanks

K

Tags

You might want to read this about upgrades....

http://nobmob.com/node/36308

Although I have the firmware you refer to and don't have any such 'drift' issues. It's quite normal when you stand still for any decent length of time that the signal will 'drift' around due to the accuracy of these things. Eg.... you might look to have moved in a small circle. If you go inside then maybe that circle would be larger than standing still outside.

How far does it say you are moving? If it's 100s of metres that's a bit suss.

I had several issues with the upgrade. If you don't need all the new power related stuff, I strongly recommend rolling back to v2.8. I managed it by googling for the old version - someone was hosting the file I think.

Cheers,
Dave

It seems to have sorted itself out now. Weird. Thanks for the tips anyway. I'll be watching it closely from now on.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Best Mountain Bike